Почему при обновлении с LTS на следующую версию появляется сообщение «Новая версия не найдена»?

Убунту 21

Обновление вашей системы Ubuntu с версии LTS (долгосрочная поддержка) до следующего выпуска иногда может привести к появлению сообщения об ошибке: «Новый выпуск не найден». Это может сбивать с толку и разочаровывать, но это распространенная проблема, которую можно решить, выполнив несколько шагов. В этой статье мы рассмотрим, почему это происходит и как это можно исправить.

При обновлении версии Ubuntu с LTS (долгосрочная поддержка) до следующего выпуска может появиться сообщение об ошибке «Новый выпуск не найден». Обычно это происходит потому, что первый выпуск новой версии еще не доступен или информация о выпуске не была обновлена. Чтобы выполнить обновление до первого точечного выпуска, вы можете использовать параметр -d в инструменте обновления или изменить параметр «Подсказка» в файле /etc/update-manager/release-upgrades. Если вы столкнулись с проблемами конфигурации прокси-сервера, проверьте различные места на наличие настроек прокси-сервера и внесите необходимые изменения.

Понимание LTS и обычных выпусков

Ubuntu предлагает два типа выпусков: LTS и обычный. Версии LTS выпускаются каждые два года и поддерживаются в течение пяти лет, тогда как обычные версии выпускаются каждые шесть месяцев и поддерживаются в течение девяти месяцев.

Когда вы используете версию LTS, система по умолчанию уведомляет вас только о новых версиях LTS. Это сделано для обеспечения стабильности, поскольку версии LTS более тщательно тестируются и, как правило, более стабильны, чем обычные версии.

Почему появляется сообщение «Новая версия не найдена»

Сообщение «Новая версия не найдена» обычно появляется по одной из двух причин:

  1. Первый точечный выпуск еще не доступен: Ubuntu не позволяет обновлять одну версию LTS до следующей, пока не станет доступен первый точечный выпуск (например, 20.04.1) новой версии. Это сделано для того, чтобы гарантировать, что все серьезные ошибки будут устранены перед обновлением пользователей LTS.
  2. Информация о выпуске еще не обновлена. В некоторых случаях информация о выпуске может не быть обновлена ​​для соответствия новой версии. Это может быть связано с недосмотром выпуска.

Как выполнить обновление до выпуска первой точки

Если вы хотите выполнить обновление до следующей версии до первой точечной версии, вы можете сделать это, используя опцию -d в инструменте обновления. Вот как:

сделать-релиз-обновление -d

или

менеджер обновлений -d

Опция -d означает разработку, что означает, что она будет обновлена ​​до разрабатываемой версии, даже если она еще не была официально выпущена.

Как обновить терминал

Если вы работаете с терминала без доступа к графическому интерфейсу, вы можете изменить файл /etc/update-manager/release-upgrades, установив для параметра «Подсказка» значение «обычный» или «lts». Вот как:

sudo nano /etc/update-manager/release-upgrades

Измените последнюю строку на Prompt=normal или Prompt=lts и сохраните файл. Затем используйте команду do-release-upgrade, чтобы проверить наличие новой версии и выполнить обновление.

Решение проблем с настройкой прокси-сервера

Если в процессе обновления вы столкнулись с сообщением об ошибке «результат загрузки мета-релиза: '<время ожидания ошибки urlopen>'», это может быть связано с проблемой конфигурации прокси-сервера. Вы можете проверить различные места на предмет настроек прокси, включая общесистемные настройки, переменные среды bash, настройки прокси-сервера gconf gnome и определенные файлы конфигурации, такие как /root/.synaptic/synaptic.conf. Удаление или редактирование этих настроек прокси-сервера может решить проблему.

Заключение

Хотя ошибка «Новая версия не найдена» может расстраивать, понимание того, почему она возникает и как ее устранить, может значительно упростить процесс обновления с версии LTS до следующей версии. Всегда не забывайте следовать рекомендуемым процедурам обновления и учитывайте любые потенциальные проблемы, связанные с информацией о выпуске или конфигурациями прокси-сервера. Если вы не уверены, всегда лучше дождаться первого выпуска новой версии перед обновлением.

Версии LTS (долгосрочная поддержка) выпускаются каждые два года и поддерживаются в течение пяти лет, тогда как обычные версии выпускаются каждые шесть месяцев и поддерживаются в течение девяти месяцев.

Это сообщение может появиться, если первый выпуск новой версии еще не доступен или если информация о выпуске еще не обновлена.

Вы можете использовать опцию -d с инструментом обновления, запустив do-release-upgrade -d или update-manager -d.

Вы можете использовать команду sudo nano /etc/update-manager/release-upgrades, чтобы открыть файл и изменить параметр «Подсказка» на обычный или lts.

Если вы столкнулись с проблемой конфигурации прокси-сервера, вы можете проверить различные места на наличие настроек прокси-сервера и удалить или отредактировать их, чтобы решить проблему. Места для проверки включают общесистемные настройки, переменные среды bash, настройки прокси-сервера gconf gnome и определенные файлы конфигурации, такие как /root/.synaptic/synaptic.conf.

Обычно перед обновлением рекомендуется дождаться первого выпуска новой версии, поскольку это гарантирует устранение любых серьезных ошибок. Однако, если вы хотите выполнить обновление до первого выпуска, вы можете использовать опцию -d или изменить файл обновлений выпуска, как упоминалось ранее.

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *